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Introduction to Spreadsheet Program 

A spreadsheet is a table of values arranged in rows and columns. In the application, each value sits in a cell. The user can define what type of data is in each cell and how different cells depend on one another. The relationship between cells is called formulae and the names of cells are called labels. 

The spreadsheet application is a program that lets users create and manipulate spreadsheets electronically. Once a group of cells are defined, and the formulae for liking them together, the user can enter its data and also, the user can modify selected values to see how the other values change automatically.

A simple example of the spreadsheet application is to calculate the mortgage payment on a house. The user will define certain cells e.g. cost of house, down payment, mortgage rate, mortgage length, monthly payment. The formula is the link between these cells.

 

Menu Bar

The spreadsheet window appears with a menu at the top of the screen. The menu contains the following headings:

· File: Disk input and output of spreadsheet data files, printing, and exit.

·  Edit: Cut, copy, paste

·  Format: Cell width, Font, decimal, and alignment

· Functions: Sum, average, max, square root, Count, and Sine

 

How to enter data

Data for different variables are entered in different columns of the spreadsheet. All data for a single subject or case are entered in one row of the spreadsheet. In the top row of the columns you can enter the names of the variable. When a string is entered and the length is longer than the cell width, the string will appear as if it is in the next cell but it is not. If the next cell contains data, only characters within the cell width is displayed while the rest remains but is not displayed. 

There are three types of data.

· Numbers: 1, 3, 5 (Used for calculation)

· Text: Strings, alphabets or number containing any non-number e.g. SSN 579-15-8565 is a text.

· Formula: =D8*C7 (Multiply content of cell D8 with cell C7 and put the result here (the current cell)). 

The user must save the file regularly.

If a user does not save the file, the data will be lost when: 

· Exit application

· Switch off the computer

· Power failure 

 

The user can also align, change cell width and font properties of every cell using the Format menu. Empty cells and alphabets are mathematically counted as zero. 

 

Error/Prompts

The program has several error message prompts that informs the user of errors and an appropriate guess of the correct action. For example, an error message appears when a string appears in a cell within a formula or when a negative number is placed in a Sine function. A prompt message appears when a user exits without saving a spreadsheet.

 

How to save data

To save a file for the first time, the user will go to the File menu and use Save As menu to save the spreadsheet otherwise the Save sub menu under the File menu is used to save spreadsheets. 

· Save in: select the directory where you want to save the data file.

· File Name: select or type the name of the file for the data.  Using quotes around the file name will force the extension to the user’s liking. If the filename is in quotes, the file will be saved as specified.  For example, saving the file as a.pl with the current extension as .txt will save the file as a.pl.txt.  Saving the file as “a.pl” will save the file as a.pl.
Spreadsheet Services List 

1.

Service: Open File
Rationale: The user can open any existing file with a specified extension in order to do their work
Specification: Users can select this function either from the File menu, a shortcut key, or by clicking the appropriate icon on the toolbar.  
Viewpoints: Spreadsheet User

Non-functional Requirements: The program must be able to interface with the local computer’s file system.
2.

Service: Create File

Rationale: So the user can create a new spreadsheet to work with.

Specification: User can select this function either from the File menu, a shortcut key, or by clicking the appropriate icon on the toolbar.

Viewpoints: Data Manager

Non-functional Requirements:

3.

Service: Save File

Rationale: The user can save the data and format of their currently loaded spreadsheet under the current file name, if one exists. If one doesn’t exist, a new file is created.  This function will allow the user to save using a specified extension if a new file is to be created.
Specification: User can select this function either from the File menu, a shortcut key, or by clicking the appropriate icon on the toolbar.  Users will be able to save a file from a file chooser unless the filename is in quotes.  If the filename is in quotes, the file will be saved as specified.  For example, saving the file as a.pl with the current extension as .txt will save the file as a.pl.txt.  Saving the file as “a.pl” will save the file as a.pl.
Viewpoints: Spreadsheet User

Non-functional Requirements: The program must be able to interface with the local computer’s file system and space must be available for the creation of a new file, if one doesn’t already exist with the same name.

4.

Service: Save As

Rationale: So the user can save the data and format of their currently loaded spreadsheet under a newly created file.  This function will allow the user to save using a specified extension.

Specification: User can select this function either from the File menu, a shortcut key, or by clicking the appropriate icon on the toolbar.  Users will be able to save a file from a file chooser unless the filename is in quotes.  If the filename is in quotes, the file will be saved as specified.  For example, saving the file as a.pl with the current extension as .txt will save the file as a.pl.txt.  Saving the file as “a.pl” will save the file as a.pl.

Viewpoints: Spreadsheet User

Non-functional Requirements: The program must be able to interface with the local computer’s file system and space must be available for the creation of a new file.

5.

Service: Print

Rationale: In order to create a printed copy of the spreadsheet, this service must exist.

Specification: User can select this function either from the File menu, a shortcut key, or by clicking the appropriate icon on the toolbar.

Viewpoints: Data Viewer

Non-functional Requirements: The program must be able to work with the local computer’s printing services.

6.

Service: Cut

Rationale: User can use this function to cut data, including formulas, from one cell to another or to other applications.

Specification: User can select this function either from the Edit menu, a shortcut key, or by clicking the appropriate icon on the toolbar.

Viewpoints: All Viewpoints 

Non-functional Requirements: This function must be able to work with the paste service in order to paste data to another cell or application. Also, there must exist a system-wide clipboard to place the data on after the cut operation.

7.

Service: Copy

Rationale: User can use this function to copy data, including formulas, from one cell and use the associated function “paste” to paste the data into another cell or application.

Specification: User can select this function either from the Edit menu, a shortcut key, or by clicking the appropriate icon on the toolbar.

Viewpoints: All Viewpoints

Non-functional Requirements: This function must be able to work with the paste service in order to paste data to another cell or application. Also, there must exist a system-wide clipboard to place the data on after the cut operation.

8. 
Service: Paste

Rationale: User can use this function to paste the data, including formulas, received from the system clipboard, into the currently selected cell(s).

Specification: User can select this function either from the Edit menu, a shortcut key, or by clicking the appropriate icon on the toolbar.

Viewpoints: All Viewpoints 

Non-functional Requirements: This function must be able to work with “cut” and “copy” function in order to paste data onto their desired cell(s). To do this, a system-level clipboard must be available.

9.

Service: Resizable Grid

Rationale: This function will enable user to define the size of each column as they desire.

Specification: User can use this function by dynamically changing the column size in the column header area with the mouse.

Viewpoints: All Viewpoints 

Non-functional Requirements: There should be a size constraint that the size of a cell should not be bigger than the system defined maximum size.

10. 

Service: Font Size/Color/Style

Rationale: Users can use this function to set the desired font size and format, including font, font size, font style, font color, and cell background color.

Specification: Users can select this function either from the Format menu, a shortcut key, or by clicking the appropriate icon on the toolbar.

Viewpoints: Chart Creator

11. 

Service: Keyboard Entry

Rationale: The user must be able to enter data into each cell and into the function field.

Specification: Keyboard entry is possible when either an individual cell or the function field is selected and no modal dialog boxes are present.

Viewpoints: All Viewpoints

12.
Service: Pop-up Menus

Rationale: Often it is simplest to have a menu tailored to currently available actions that can appear where the cursor is

Specification: The user performs the action consistent with their operating system to call pop-up menus (right-click, command-click, etc).

Viewpoints: Regular User, Personal Organizer

Non-functional Requirements: The system must have mouse support.

13.

Service: Border

Rationale: Borders around a cell or cells help organize data and draw attention to certain areas of the spreadsheet. 

Specification: One or more cells must be selected when the user chooses to create a border. The service is chosen through the Format menu, a shortcut key, or the by clicking the appropriate button on the toolbar. A rectangular border is then displayed surrounding the cell or cells.

Viewpoints: Chart Creator

14.

Service: Column Names

Rationale: Columns should be nameable to add to the readability of the spreadsheet. This allows the data in named columns to be quickly identified.

Specification: The user double-clicks the title for the column to be edited and types in the new name. Each column has a default name defined by its position within the spreadsheet.

Viewpoints: Chart Creator 

15.

Service: Data Types

Rationale: The user should be able to differentiate between string and numerical data. 
Specification: The system will attempt to automatically detect if a cell’s contents are of a certain type. There will, however, exist a method for the user to manually select the cell data type.

Viewpoints: Professional 

16.
Service: Data Functions

Rationale: Mathematical functions should exist which allow the user to perform calculations using data from the spreadsheet.

Specification: The user can either input formulas using a special prefix in each cell or in the function entry area.

Viewpoints: Professional 

17.

Service:  Without Absolute Addressing

Rationale: When users are using copy and paste functionality, the cell(s) which they are selected may have mathematical functions behind them. In this case, the mathematical functions will also copy to the new cell and the mathematical function will update according to their new position.

Specification: The user can select cell(s), copy and paste them in to a new position in the spreadsheet. The mathematical function behind the cell(s) will get update according to their new position.

Viewpoints: Professional 

18.
Service: Undo function

Rationale: Users will be allowed to roll back to a previous state before the latest change was made.

Specification: Users can select this function from the Edit menu or a shortcut key. The application will keep track of the latest 15 changes in a history list for the undo functionality.

Viewpoints: Spreadsheet User

Non-functional Requirements: 

19.

Service: Quotes used for strings

Rationale: Users can surround a formula with double-quotes to indicate that it is to be processed as a string.

Specification: Users can use quotes inside any spreadsheet cell. The application will process the data in the cell as a string.

Viewpoints: Spreadsheet User

Non-functional Requirements:

20.

Service: Insert new row

Rationale: Users will be allowed to insert a new row to the end of the current spreadsheet.

Specification: Users can access this function from the Edit menu or a shortcut key. The application will draw a new row with empty cells to the end of the current spreadsheet.

Viewpoints: Spreadsheet User

Non-functional Requirements:

21.

Service: Insert new column

Rationale: Users will be allowed to insert a new column to the end of the current spreadsheet.

Specification: Users can access this function from the Edit menu or a shortcut key. The application will draw a new column will empty cells to the end of the current spreadsheet.

Viewpoints: Spreadsheet User

Non-functional Requirements:

22.

Service: Delete row

Rationale: Users will be allowed to delete a selected row from the current spreadsheet.

Specification: Users can access this function from the Edit menu or a shortcut key. The application will delete the currently selected row or rows from the current spreadsheet. The application will readjust the remaining rows and re-process all existing cells.

Viewpoints: Spreadsheet User

Non-functional Requirements:

23.

Service: Delete column

Rationale: Users will be allowed to delete a selected column from the current spreadsheet.

Specification: Users can access this function from the Edit menu or a shortcut key. The application will delete the currently selected column from the current spreadsheet. The application will readjust the remaining columns and re-process all existing cells.

Viewpoints: Spreadsheet User

Non-functional Requirements:

24.

Service: Document history

Rationale: A list of recently viewed documents will be listed for easy retrieval.

Specification: Users can access this functionality from the File menu. The application will keep a list of recently viewed documents for the users to choose from without using the Open function in the File menu. 

Viewpoints: Spreadsheet User

Non-functional Requirements: The application should make sure that the selected file still exists before putting them in the list. If a file does not exist anymore, remove it from the Document History.

25.

Service: Drawing graphs from spreadsheet data

Rationale: The ability to draw Column, Line, Pie, and Row type graphs using selected data from the spreadsheet.

Specification: Users will be able to select an entire spreadsheet document or selected pieces of a document to draw Column, Line, Pie, and Row type graphs. These graphs will be displayed on a separate window from that of the spreadsheet. The function can be accessed from the Graph menu.

Viewpoints: Data Viewer, Chart Creator

Non-functional Requirements: The user should be able to copy the graph image to the clipboard. The user should be able to print the graph image to a printer.

26. 

Service: Help function

Rationale: Users will be redirected to an HTML document that contains help material on functions and services of the application.

Specification: The user can access the function from the Help menu or a shortcut key. The help HTML document will be displayed in a separate window from that of the Spreadsheet document. The user should be able to print the HTML document to a printer.

Viewpoints: All Viewpoints

Non-functional Requirements:

27.

Service: About page

Rationale: Displays the application name, company name, version number, and any other necessary information about the application.

Specification: The user can access this function from the Help menu. The about page will be displayed on a separate window from that of the spreadsheet document.

Viewpoints: All Viewpoints

Non-functional Requirements:

28.

Service: Saving and restoring window state

Rationale: The application should save window state before closing the application. The application should restore the window state when the application is started again.

Specification: Before exiting, the application will automatically save the current size and location of the window to a data file. Upon starting, the application will automatically restore the window size and location according to what was saved from the previous session using the data file.

Viewpoints: All viewpoints

Non-functional Requirements:

29:

Service: Find function

Rationale: Users will be able to search for a specific string in the spreadsheet document.

Specification: This function can be accessed from the Edit menu or a shortcut. Users will be able to type in a string and the application will search the entire document for it. When each instance of the search-string is found, the search-string will be highlighted in the document and the process stops. 

Viewpoints: Spreadsheet User

Non-functional Requirements:

30.

Service: Find and Replace function

Rationale: Users will be able to search for a string in the spreadsheet document and have the option to replace it with another string of choice.

Specification: Users can access this function from the Edit menu or a shortcut. The find function will work similar to the Find function mentioned above. When an instance of the search-string is found, the user will be given a choice of whether to replace it with another string. The user will also be given an option to replace every instance of string with another without prompting at each one (Replace All).

Viewpoints: Spreadsheet User

Non-functional requirements:

31.

Service: Hotkeys

Rationale: Users will be able to access menu items with keyboard shortcuts (hotkeys).

Specification: The following is a list of menu items with their corresponding hotkey. A hotkey is executed when the Control key is held down and the appropriate letter is pressed: (N) New File, (O) Open File, (S) Save, (P) Print, (Z) Undo, (X) Cut, (C) Copy, (V) Paste, (F) Find, (H) Help

Viewpoints: Spreadsheet User

Non-functional requirements:

32.

Service: Merge cells

Rationale: Users will be able to merge together two or more cells (source) into a single cell (destination).

Specification: This function can be accessed from the Functions menu.  Users will be able to select multiple continuous cells and merge all contents into a single cell.  A single cell containing all contents will replace the cells that were selected.

Viewpoints: Grid User, Spreadsheet User

Non-functional requirements:

33.

Service: User Defined Functions

Rationale: Users will be able to define and import their own functions as a plug-in to TerpSpreadsheet.

Specification: This function can be accessed from the Functions menu.  Users will be able to specify their own formulas for computation using plug-ins which can be selected/added through the menu.
Viewpoints: All viewpoints
Non-functional requirements:

34.

Service: Dynamic sizing of rows and columns

Rationale: This function will enable users to insert and delete rows and columns from the 

spreadsheet dynamically.

Specification: This function can be accessed from the Format menu.  Users will be able to add as many rows or columns as needed.  Users will also be able to select any row or column to delete. 

Viewpoints: Grid User, Spreadsheet User

Non-functional requirements:

35.

Service: User Defined Graphs
Rationale: User will need to be able to create a wide variety of graphs to plot the data. On occasions the user will need to define a graph type that is not built into the Software package. This will allow user to have an unlimited ways to graph the data in the application and will allow the user to fully customize the way the data will be plotted.

Specification: The user will be provided a basic tutorial on how to develop his/her own graph types. Once the user is familiar with the graph defining procedure, he/she can then create a new graph type that follows the documented standard (outlined in the tutorial). When done with the graph creation, the user will then place the new graph type into a specified directory, where upon loading the program; the new graph type will be added to the already built-in graphs. To use the new graph, the user will select Graph from the menu and then go to the User Defined submenu to access the user defined graphs.

Viewpoints: Chart Creator and Chart Developer 

Non-functional requirements
36.

Service: Non-contiguous Cell Selection
Rationale: The User should be able to select cells that are not adjacent to each other.

Specification: In any case in which a user can select multiple cells, the user will be able to select any set of cells. The user will be able to achieve this by holding the control key while selecting cells. Holding the control key will indicate to the program that cells are still being selected, overriding the signal in which releasing the mouse would indicate that cells are no longer being selected.

Viewpoints: All Viewpoints

Non-functional requirements:

37.

Service: Live Preview of Application Files
Rationale: Allows the user to immediately preview image files in JPEG,

BMP, or GIF format without opening the file with an application.

Also allows the user preview other files associated with TerpOffice

applications.

Specification: A thumbnail image will be provided on the side of the

exploration window, showing a small version of the currently selected

file.   Non-graphic files will show an image of the first page

viewable in the file.
Viewpoints: All viewpoints
Non-functional requirements:

Spreadsheet User View Points 

The four major viewpoints for spreadsheet users are the Data Viewer, Grid User, Chart Creator, and the Professional User.  Where the Grid User is a simple user that only creates simple tables in the spreadsheets and pastes them somewhere else.  Data Viewer would be a clerical worker that prints out or checks a schedule or a plan created by his supervisor.  A Chart Creator is a manager or an organizer that uses spreadsheets to create tables, schedules, or to track other data.  A Professional User is someone who uses spreadsheets to analyze data. Finally, a Chart Developer is someone who creates the plug-ins used by TerpSpreadSheet in the case a pre-defined chart does not suite their needs.
Final View Points

1.

View Point: 
Data Viewer – this user views spreadsheet documents created by others to keep track of events, data.

Attributes: 
Name of the spreadsheet.

Actions: 
View Spreadsheet

Services: 

· Grid: 
The User should have a resizable grid for his actions.

· Open File: 
The User should be able to open an existing spreadsheet.

· Save File: 
The User should be able to save the file as a different name.

· Find: 
The User should be able to find any instance of a string or number.

· Print Full: 
The User has the ability to print the entire spreadsheet including all elements in the range of the defined rows and columns.

· Document History: 
The User should be able to view the four most recent spreadsheet documents used in the file drop down menu.

· Help: 
The User may select “Help” from the menu bar and it will link to a website that will give the user information about how to use the spreadsheet.

· About: 
“Help” menu bar option which details the information about the developers of the spreadsheet program.

2.

View Point: 
Grid User – this user uses a spreadsheet grid to create tables, and to use them in other applications.

Attributes: 
Dimensions of the table, Data

Actions: 
Create Table, Use Result

Services: 

· Keyboard Entry:  
The User should be able to enter data from the keyboard into the table.

· Grid: 
The User should have a resizable grid for his actions.

· Copy/Paste:
The User should be able to copy/paste a group of cells within the application.

· Paste between applications: 
The User should be able to use the created table in another application.

· Copy between applications: 
The User should be able to use data from another application.

· AutoFit: 
The User should be able to resize a column to the length of the longest cell in the column.

· Undo/Redo: 
The User should be able to undo/redo a group of cells within the application.

· Insert Row/Col: 
The User should be able to insert an entire row or column.

· Delete Row/Col:
The User should be able to delete an entire row or column.

· Find/Replace: 
The User should be able to find any instance of a string and replace it.

· Hotkeys: 
The User may use hotkeys for items appearing in the spreadsheet menus.

· Pure Text Paste: 
The User may paste values from the cells without having their formulas pasted along with them.

· Simple Text Enter: 
The User may use quotes to indicate pure text to enter into cell.

· Print Full: 
The User has the ability to print the entire spreadsheet including all elements in the range of the defined rows and columns.

· Document History: 
The User should be able to view the four most recent spreadsheet documents used in the file drop down menu.

· Help: 
The User may select “Help” from the menu bar and it will link to a website that will give the user information about how to use the spreadsheet.

· About: 
“Help” menu bar option which details the information about the developers of the spreadsheet program.
· Merge Cells: 
The User may select more than one cell and be able to merge their contents into a single cell.
· Dynamic Sizing:
Users will be able to insert and delete rows and columns from the spreadsheet dynamically.

3.

View Point: 
Chart Creator – this user uses spreadsheet document to create organizational documents such as schedules and inventory.

Attributes: 
Name of the spreadsheet, Dimensions of the table, Names for columns/rows, Fonts, Cell Colors, Dimensions for Borders.

Actions: 
Organize Data, Format Organization, Store Result.

Services: 

· Create Custom Chart:
The User should be able to create a customized chart specific to his particular needs. 
· Enter Data from a keyboard:  
The User should be able to enter data from the keyboard into the table.

· Grid: 
The User should have a resizable grid for his actions.

· Copy/Paste: 
The User should be able to copy/paste a group of cells within the application.
· Open File: 
The User should be able to open an existing spreadsheet.

· Save File: 
The User should be able to save the spreadsheet if changes have been made.

· Create File: 
The User should be able to create a new spreadsheet

· Fonts/Colors: 
The User should be able to format each individual cell to his preference.

· Shortcuts for Formatting/Colors: 
On menu taskbar, pull-down menu for formatting of cells 


and for selecting colors.

· Borders: 
The User should be able to create a border around a group of cells.

· Column Names: 
The User should be able to provide a name for his columns.

· AutoFit: 
The User should be able to resize a column to the length of the longest cell in the column.

· Undo/Redo: 
The User should be able to undo/redo a group of cells within the application.

· Insert Row/Col: 
The User should be able to insert a row or column.

· Delete Row/Col:
The User should be able to delete a row or column.

· Find/Replace: 
The User should be able to find any instance of a string and replace it.

· Textfield Taskbar: 
The User may enter formulas and text into the delegated space on the taskbar.

· Hotkeys: 
The User may use hotkeys for items appearing in the spreadsheet menus.

· Pure Text Paste: 
The User may paste values from the cells without having their formulas pasted along with them.

· Simple Text Enter: 
The User may use quotes to indicate pure text to enter into cell.

· Print Full: 
The User has the ability to print the entire spreadsheet including all elements in the range of the defined rows and columns.

· Document History: 
The User should be able to view the four most recent spreadsheet documents used in the file drop down menu.

· Help: 
The User may select “Help” from the menu bar and it will link to a website that will give the user information about how to use the spreadsheet.

· About: 
“Help” menu bar option which details the information about the developers of the spreadsheet program.

· User Defined Graphs:
The User should be able to plot data specific to their needs, allowing custom graphs and unlimited selection.

4.

View Point: 
Professional User – this is a user who uses spreadsheets to analyze data.

Attributes: 
Name of the spreadsheets, Names for columns/rows, Data type, Analysis, 
Formulas, Data layout.

Actions:  
Organize Data, Analyze Data

Services: 

· Create Custom Chart:
The User should be able to create a customized chart specific to his particular needs. 

· Plug-Ins:
The User should be able to call a java routine on specified cells, and have the results pasted into specified cells on the spreadsheet.
· Enter Data from a keyboard:  




The User should be able to enter data from the keyboard 




into the table.

· Grid: 
The User should have a resizable grid for his actions.

· Copy/Paste: 
The User should be able to copy/paste a group of cells within the application.

· Open File: 
The User should be able to open an existing spreadsheet.

· Save File: 
The User should be able to save the spreadsheet if changes have been made.

· Create File: 
The User should be able to create a new spreadsheet.

· Data Types: 
The User should be able to specify that he wants a number or a string in the grid cell.

· Data Functions: 
The User should have access to a set of functions on numerical or string data.

· Absolute Addressing: The User should be able to use absolute addressing for the columns in the spreadsheet.

· Undo/Redo: 
The User should be able to undo/redo a group of cells within the application.

· Insert Row/Col: 
The User should be able to insert a row or column.

· Delete Row/Col:
The User should be able to delete a row or column.

· Find/Replace: 
The User should be able to find any instance of a string and be able to replace it.

· Textfield Taskbar: 
The User may enter formulas and text into the delegated space on the taskbar.
· Hotkeys: 
The User may use hotkeys for items appearing in the spreadsheet menus.

· Pure Text Paste: 
The User may paste values from the cells without having their formulas pasted along with them.

· Simple Text Enter: 
The User may use quotes to indicate pure text to enter into cell.

· Print Full: 
The User has the ability to print the entire spreadsheet including all elements in the range of the defined rows and columns.

· Document History: 
The User should be able to view the four most recent spreadsheet documents used in the file drop down menu.

· Graphs: 
The User is able to select certain cells and use the values in those cells to create graphs which include Column, Line, Pie, and Row graphs.

· Help: 
The User may select “Help” from the menu bar and it will link to a website that will give the user information about how to use the spreadsheet.

· About: 
“Help” menu bar option which details the information about the developers of the spreadsheet program.

· Shortcuts for Formatting/Colors: 




On menu taskbar, pulldown menu for formatting of cells 




and for selecting colors.

5.

View Point: 
Chart Developer – this is a user who creates plug-ins for TerpSpreadSheet which can be defined/programmed by this user for their specific needs.

Attributes: 
Name of the spreadsheet, Name of chart, Data types, Data layout.

Actions:  
Organize Data, Define Parameters for Charts, Format Organization, Analyze Data
Services: 
· User Defined Graphs: The user will be able to create a wide variety of graphs to  plot the data.
· About: 
“Help” menu bar option which details the information about the developers of the spreadsheet program.

· Help: 
The User may select “Help” from the menu bar and it will link to a website that will give the user information about how to use the spreadsheet.

Intermediate View Points 

Since the some of the final viewpoints share the same functionality, we introduced intermediate viewpoints for the viewpoint hierarchy and moved common functionality into intermediates.  The intermediate viewpoints are: All View Points, Spreadsheet User, and Data Manager. The Italic bullets represent the inherited services.

1.

View Point: 
All View Points – this viewpoint contains functionality common for all 
viewpoints.

Attributes: 
Data

Actions: 
Create table, Use Result

Services: 

· Enter Data from a keyboard:  




The User should be able to enter data from the keyboard 




into the table.

· Grid: 
The User should have a resizable grid for his actions.

· Copy/Paste: 
The User should be able to copy/paste a group of cells within the application.

· AutoFit: 
The User should be able to resize a column to the length of the longest cell in the column.

· Print Full: 
The User has the ability to print the entire spreadsheet including all elements in the range of the defined rows and columns.

· Document History: 
The User should be able to view the four most recent spreadsheet documents used in the file drop down menu.

· Help: 
The User may select “Help” from the menu bar and it will link to a website that will give the user information about how to use the spreadsheet.

· About: 
“Help” menu bar option which details the information about the developers of the spreadsheet program.

· Non-contiguous Cell Selection: 
The User should be able to select cells that are not adjacent to each other.

· User Defined Functions:
Users will be able to define and import their own functions as a plug-in to TerpSpreadsheet.
· Live Preview of Application Files:
Allows the user to immediately preview image files in JPEG, BMP, or GIF format without opening the file with an application. Also allows the user preview other files associated with TerpOffice applications.

Sub-Viewpoints: 
Grid User, Spreadsheet User.

2.

View Point: 
Spreadsheet User – this viewpoint contains functionality common for 
everyone who uses spreadsheet files in the spreadsheet application.

Attributes: 
Data

Actions: 
Create Table, Use Result

Services: 

· Enter Data from a keyboard:  




The User should be able to enter data from the keyboard 




into the table.

· Grid: 
The User should have a resizable grid for his actions.

· Copy/Paste: 
The User should be able to copy/paste a group of cells within the application.

· Open File: 
The User should be able to open an existing spreadsheet.

· Save File: 
The User should be able to save the spreadsheet if changes have been made.

· AutoFit: 
The User should be able to resize a column to the length of the longest cell in the column.

· Undo/Redo: 
The User should be able to undo/redo a group of cells within the application.

· Insert Row/Col: 
The User should be able to insert a row or column.

· Delete Row/Col:
The User should be able to delete a row or column.

· Find/Replace: 
The User should be able to find any instance of a string and be able to replace it.

· Hotkeys: 
The User may use hotkeys for items appearing in the spreadsheet menus.

· Pure Text Paste:
 The User may paste values from the cells without having their formulas pasted along with them.

· Simple Text Enter: 
The User may use quotes to indicate pure text to enter into cell.
· Merge Cells: 
The User may select more than one cell and be able to merge their contents into a single cell.

· Dynamic Sizing:
Users will be able  to insert and delete rows and columns from the spreadsheet dynamically.

Sub-Viewpoints: 
Data Viewer, Data Manager.

3.

View Point: 
Data Manager – this viewpoint combines common services for all the 
users that create new spreadsheets.

Attributes: 
Data

Actions: 
Create Table, Use Result.

Services: 

· Create Custom Chart:
The User should be able to create a customized chart specific to his particular needs. 

· Enter Data from a keyboard:  




The User should be able to enter data from the keyboard 




into the table.

· Grid: 
The User should have a resizable grid for his actions.

· Copy/Paste: 
The User should be able to copy/paste a group of cells within the application.

· Open File: 
The User should be able to open an existing spreadsheet.

· Save File: 
The User should be able to save the spreadsheet if changes have been made.

· Create File: 
The User should be able to create a new spreadsheet.

· Textfield Taskbar: 
The User may enter formulas and text into the delegated space on the taskbar.
· Shortcuts for Formatting/Colors: 




On menu taskbar, pull-down menu for formatting of cells 




and for selecting colors.

Sub-Viewpoints: 
Chart Creator, Chart Developer, Professional.

Charts and Diagrams 
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Figure 1 Hierarchy of viewpoints

Figure 2 Services for Each Viewpoint
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