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combinations and orderings of events1 is not practical, as the
number of test cases that would be required is exponential in
the number of events. Instead, testers of GUI applications
attempt to limit the number of test cases that need to be
executed. Due to the event-driven nature of GUI software,
GUI testing requires diﬀerent techniques than those used in
conventional testing [13].
Although it seems the code that makes up the interface to
the application would not be very substantial, it generally
makes up 45-60% of the overall code and can house faults
[15]. Errors in the GUI can manifest themselves as failures
of the overall software. Therefore, it is important to test the
GUI.
This paper presents a technique that can be used for regression testing of GUI applications, i.e., information gathered from usage of the current version of a GUI application
is used to determine whether the new application will perform as expected. Previous work on GUI regression testing
showed that test suites covering all feasible pairs of events,
called smoke tests, detect a large number of faults [14].
Many of these event sequences are unlikely to occur in actual usage of the software. For instance, the event sequence
Save followed by Save As is a valid test case in the smoke test
suite (represented as the ordered pair (Save, SaveAs)), but
is not very likely to occur in actual usage of the software.
Conversely, the event sequence that represents formatting a
document (for instance, adding tables and ﬁgures, or changing font size, style, and color) is very likely, but will not be
contained in the smoke test suite since formatting requires
a sequence of more than two events, and smoke tests are
restricted to sequences of two events. In previous work, we
have shown that event sequences longer than two events reveal many faults not detected by the smoke test suite [14].
Including these test cases in the smoke test suite, however, is
not a viable solution since increasing the test suite from all
possible pairs of events to all possible triples, . . ., n-tuples
causes it to grow exponentially [14].
To counteract this exponential test suite growth, another
approach, and the one used in this paper, is to automatically
generate test cases based on usage information, in the form
of “usage proﬁles,” collected from end-users interacting with
a ﬁelded version of the application. Usage proﬁles (called operational proﬁles [24] or session data [6] in some literature)
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1.

INTRODUCTION

The most popular user interface for software today is the
graphical user interface (GUI), providing user-friendly access to the functionality provided by the application. Testing GUIs, however, presents many challenges, primarily due
to the immense number of possible permutations of commands that can be executed on the GUI. Testing all possible
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1
An event is a user action that can be performed on a GUI
widget, such as clicking on a button or a menu item, or
typing in a text ﬁeld. In the remainder of this paper, wherever possible, events will be denoted by their corresponding
widget; for example, click on Cancel button will be called
Cancel and click on menu item Save will be called Save.
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can be obtained by capturing event sequences users execute
on the GUI application. Because they are gathered from
actual usage of the software, any faults detected by using
them represent faults likely to be encountered by users in
the ﬁeld. After collection, proﬁles can be used in two ways:
they can be replayed directly or used to create a model of
the application which can be used for testing. Using an automatic test case replayer to replay the proﬁles directly on a
modiﬁed version of the GUI application is the most straightforward approach [16]. Due to possible structural changes
to the GUI, this is not a good approach for regression testing, however, since as many as 75% of the event sequences
may no longer execute on the modiﬁed application [13]. The
second approach, and the focus of this paper, is to employ
the usage proﬁles to create and update an abstract model
of the GUI application and use the model to generate test
cases automatically.
In this paper, a new technique is presented to capture
GUI user proﬁles in a transparent manner and with very
little overhead, employ the proﬁles to populate a probabilistic model of the GUI application, and generate test cases
from this model. An empirical study was conducted on four
open source applications to measure the beneﬁt user proﬁles
add to the regression testing process. After collecting user
proﬁles, the probabilistic model was populated and used to
generate test cases corresponding to the concatenation of
many short, highly likely event subsequences. Test cases
generated by the model were ordered by the likelihood of
occurring in actual use; therefore, the test suite was composed of test cases that were most indicative of actual use
of the application. The challenge of collecting proﬁles was
mitigated by using a proﬁling tool that runs in the background, with very little impact on performance of the application. Two test suites were compared: one composed
of test cases replayed directly from a set of collected user
proﬁles and one composed of test cases generated from our
model (populated with the same set of usage proﬁles). The
results show that the test suites generated from our model
detected more faults per test case than replaying the proﬁles
directly, and with a fraction of the number of test cases in
the original proﬁles suite, thereby reducing the cost of testing. Additionally, the test cases generated from the model
detect faults that are not detected by replaying the original
proﬁles; these are faults that are likely to be discovered by
users of the application.
The work presented in this paper provides the following
primary contributions:

models in testing and usage proﬁle-based testing. The details of the model used in this paper are elucidated in Section 3. Section 4 contains a description of the empirical
studies and the results are presented in Section 5. Finally,
conclusions and future work are described in Section 6.

2. RELATED WORK
Previous researchers have studied the eﬀectiveness of collecting information from users, either at runtime or during
software development, to be used in software testing. Our
previous work investigated replaying usage proﬁles to perform regression testing on applications, but did not employ
usage proﬁles to create a model of the application and test
the application based on that model [12]. Many of the previous approaches to testing with usage proﬁles rely on manually generating proﬁles based on a priori knowledge of the
application [23, 24]. The overall goal of testing using these
methods is to develop and implement fully automated methods in which user interactions are captured, the application
or application model is generated automatically from the
binary code, and test cases are developed and executed.
Usage proﬁle-based testing transitions nicely to testing
GUI applications. Due to the large number of events in a
GUI, user proﬁles can assist a tester in shrinking the scope
of testing by focusing test case generation on the parts of
the GUI and sequences of events most often used by actual
users. In regression testing, user proﬁles are collected on
the ﬁelded version and used to generate test cases for the
version under test. Collecting proﬁles on a ﬁelded version
of the software enables testers to accurately represent tasks
users will execute, leading to more eﬀective test cases.

2.1 Usage profile-based testing
Many researchers in software testing have used capture
and replay tools to test software, often in conjunction with
test scripts created by testers to ensure the software functions properly. The same capture/replay tools can also be
used to record usage information, in the form of event sequences executed on the application, from actual users [4,
16, 18]. The information collected can then be integrated
into test cases or used to generate test cases. Although this
approach is not widespread, it is similar to the approach
used in this work.
Operational proﬁles, generally gathered through ethnographic methods (customer interviews, videotaping, usage
logs), can also be used to develop test cases. These proﬁles
can be used to identify critical failures in a GUI application;
be used to partition users into classes of users and develop
test cases accordingly; be annotated based on expected or
actual usage of the application; and be used to determine
testing coverage, updating the proﬁle to reﬂect success or
failure [1, 5, 17, 20].
Usage data (or “session data”) has also been used to test
web applications, by generating test cases from a combination of events from diﬀerent users’ session data, creating a
new virtual user [6]. While the approach presented in this
paper uses a similar idea, it is applied to GUI applications
rather than web applications, and a probabilistic model is
populated and used to generate test cases, rather than generating test cases based solely on the user-session data.

1. a new probabilistic ﬁnite state model representation
of a GUI application that combines its static window/widget structure with actual usage,
2. a method to populate the model with user information
gathered from real application usage,
3. an algorithm to generate test cases based on the model,
and
4. an empirical investigation comparing the size and fault
detection ability of a test suite generated by our technique to a test suite of “raw” usage proﬁles on four
large, ﬁelded applications.

2.2 GUI testing

The remainder of this paper is organized as follows. Section 2 expands on work in related areas, such as using state

There are a variety of popular methods used for testing
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3. PROBABILISTIC MODEL OF GUI
INTERACTIONS

GUIs, including test harnesses, capture/replay tools, and
model-based methods. Test harnesses invoke methods in
the underlying business logic of a application, as if executed
by the GUI, without actually using the GUI [10]. While test
harnesses eﬀectively isolate the behavior of the GUI, they
do not test the interface code itself and, therefore, are not
applicable to the approach presented here.
The second approach, using manual tools to mimic the
usage of the GUI, only provides limited testing [7, 21]. JUnit, an open-source, regression testing framework used to
test Java code, has been extended into JFCUnit and Jemmy
Module for use in GUI testing [8]. Several capture/replay
tools have also been created based on JUnit, including Abbot, Jacareto, and Pounder [8]. These tools mimic actual
usage of a GUI by recording interactions with the GUI in
capture mode and replaying the interactions in replay mode.
A common approach of these tools is to store mouse coordinates, causing test cases to be fragile and dependent on the
GUI layout, and rendering many test cases ineﬀective for
regression testing since the GUI layout may change between
versions. Tools such as Winrunner2 , Abbot3 , and Rational
Robot4 avoid this problem by capturing GUI widgets rather
than mouse coordinates. These tools, however, require a
signiﬁcant amount of manual eﬀort to be eﬀective, including developing test scripts and manually detecting failures.
Modiﬁcations to the GUI require changes to the scripts as
well. Testers who employ these tools typically come up with
a small number of tests to utilize during development [11].
Finally, test cases can be generated based on a model
of the GUI. Previous research has shown the usefulness of
graphs and state machine models to represent the GUI, and
test cases were developed by exploring paths through the
model [2, 3, 14, 22]. Graph models can be walked, either
randomly or deterministically, but can not be traversed exhaustively because of the large number of possible traversals.
Therefore, it is common to traverse all paths of the graph
up to a speciﬁed length [14].
State machines are a well-known way to model complex
software. Behavioral models, in which nodes represent program states or sets of related states and edges represent
transitions between states, are one type of state-machine
model which encodes the behavior of the program. Each
test case is generated by traversing the model, representing
the path traversed [2].
Operational models, a type of state machine, use nodes
to represent user operations. Nodes, edges, or paths can
be weighted with the probability that a user traverses them.
Previous research has explored using Markov models in which
the probability on each node depends only on the previous
node [22] and using a Bayesian framework in which model
parameters can be learned and updated during testing [17].
Representing a GUI with a state machine or graph model
allows a wide variety of algorithms to be used for test case
generation, but many of the current approaches are not
based on actual usage of the software. The method presented in this paper uses a graph to model the GUI and
augments it with probabilities based on observed usage.

In developing testing strategies for GUIs, it is desirable to
develop a multi-purpose model that can be used to represent
all possible GUIs. Due to the variety of applications with a
GUI front-end, however, such a model would be required to
represent a vast number of GUIs. Therefore, we represent
one sub-class of GUIs: those which take input from a single
user, have a ﬁxed number of events, and are deterministic.
This class of GUIs can be represented by an Event-Flow
Graph (EFG) and standard graph walking techniques can be
used to reason about the model and generate test cases [14].
In developing a software model to be used in testing, it is
important that it be reusable and ﬂexible [19]. The model
described here can be used for an application in any domain, given information about sequences of events for that
application, rendering our model very ﬂexible and applicable to any GUI application in the aforementioned subclass.
In modeling expected usage, all users are treated as “average” users. Therefore, although each application under test
can potentially have many usage models (one for each class
of users), one usage model was developed per subject application for the purposes of this work. Additionally, the
model presented here gives a tester the ability to represent
the behavior of a new user, formed by combining the most
likely event sequences observed in the pool of users.

3.1 Modeling GUI structure with an Event
Flow Graph
An EFG is a speciﬁc model of the GUI for a particular application, representing all possible sequences of events that
a user can execute on that GUI. Nodes in the EFG represent
events, and directed edges represent the event-ﬂow relationship between two events. An edge in the graph between
events e1 and e2 indicates that event e2 may be invoked
immediately after event e1 . The predicate f ollows(e2 , e1 )
represents this relationship and denotes that e2 follows e1 .
EFGs are potentially cyclic, since events can typically be executed more than once during a session with an application.
For instance, a user looking for a word in a Microsoft
Word document can select the Edit menu followed by the
Find menu item, type the word they wish to ﬁnd in the
text box, and select the Find button to perform the ﬁnd
operation. The user can then ﬁnd the next occurrence of
the word by selecting Find again before selecting Cancel to
close the dialog box. Each of these events is represented by
a node in the EFG. Figure 1(a) shows a screenshot of the
Microsoft Word GUI. For increased readability, only a few
menu items for the File and Edit menus are shown. Each
item (or event) in the menu is a node in the event ﬂow
graph, shown in Figure 1(b). Three types of events are
shown in Figure 1(b); menu items in the top level menu
bar are shown in boxes, menu items from drop down menus
are shown in diamonds, and buttons in the Find/Replace
window are shown in circles. The event sequence described
above is indicated by bold lines. Because edges in an EFG
are directed, the EFG in Figure 1(b) shows the order which
must be maintained in executing events on the GUI.

2
Mercury Winrunner,
http://www.mercuryinteractive.com/products/winrunner
3
Abbot JavaGUITest Framework,
http://abbot.sourceforge.net
4
Rational Robot,
http://www.rational.com.ar/tools/robot.html

3.2 Developing a probabilistic EFG
In the work presented here, a subgraph of the EFG is produced based on observed event sequences collected in usage
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Figure 2: Example Event Flow Graph
(a)
paths can also be formed by the concatenation of two paths,
e.g., ra and rb , provided the ﬁrst event of rb f ollows the
last event of ra in the EFG.
Consider the following usage proﬁles, i.e., a set of paths
through the EFG, shown in Figure 2:

(b)

r1

=

IN IT, e1 , e2 , F IN AL

r2
r3

=
=

IN IT, e1 , e3 , e1 , e2 , F IN AL
IN IT, e1 , e2 , e2 , e2 , F IN AL

Let count(ei ) return the number of times event ei occurs
in the paths r1 , r2 , . . . , rR . The prior probability that a randomly selected event from any of r1 , r2 , . . . , rR is ei is:

Figure 1: Example using Microsoft Word: (a) Microsoft Word GUI; (b) Example Event Flow Graph
for a subset of Microsoft Word

P (ei ) =
proﬁles. Starting with the full EFG for the application under test, nodes and edges not observed in the usage proﬁles
are eliminated, resulting in a smaller EFG. Next, the tailored EFG is augmented with two special nodes, IN IT and
F IN AL, and two sets of events, the initial and ﬁnal events,
are populated. The set of initial nodes contains the ﬁrst
event of each usage proﬁle, and the set of ﬁnal nodes contains the last event in each user proﬁle. These initial and
ﬁnal node sets represent all possible ﬁrst and last events,
respectively, in the observed user interactions with the GUI.
Transitions are added from IN IT to each initial node and
from each ﬁnal node to F IN AL, constraining the EFG to
one entry point and one exit point. This property makes
the EFG conform to the rules of a Markov chain and allows
the model to take advantage of the Markov assumption [9].
Using the Markov assumption of event independence and
frequencies observed in the usage proﬁles, the EFG’s nodes
are weighted in preparation for generating test cases.
Our model contains a collection of R paths through the
EFG called r1 , r2 , . . . , rR . Each path ri where 1 ≤ i ≤ R,
consists of a sequence of n events in addition to IN IT and
F IN AL:

count(ei )
.
ΣE
j=1 count(ej )

Following the example given above, the counts and probabilities for each event are:
count(e1 ) = 4 P (e1 ) = 0.4
count(e2 ) = 5 P (e2 ) = 0.5
count(e3 ) = 1 P (e3 ) = 0.1
Now, count(ei ) and the prior probability calculation are
extended from single events to sequences of events. Let s be
a length-S subsequence of some path through the EFG (not
necessarily in r1 , r2 , . . . , rR ):
si = x 1 , x 2 , . . . , x S
∀j ej ∈ {IN IT, e1 , e2 , . . . , en−1 , F IN AL}∧
f ollows(ej+1 , ej ).
For a subsequence length of 2 (i.e., S = 2), some valid subsequences for the example are:
s1
s2
s3

ri = IN IT, x1 , x2 , . . . , xn , F IN AL;
∀j ej ∈ {e1 , e2 , . . . , en−1 }∧
f ollows(ej+1 , ej )

=
=
=

e3 , e1
e1 , e2
e2 , e2

The prior probability that a randomly selected, length-S
subsequence from any of r1 , r2 , . . . , rR turns out to be s is

where x1 , x2 , . . . , xn and e1 , e2 , . . . , en−1 are events in the
EFG, ri denotes a path, and each path ri contains only
events with a follows relationship between them. Valid

P (s) =
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count(s)
,
Σsi ∈subs(S) count(si )

where count(s) returns the number of times s occurs as
a subsequence of r1 , r2 , . . . , rR and subs(S) is the set of
all length-S subsequences in r1 , r2 , . . . , rR . For each subsequence given above, the count and probability are:

Input: Profiles, maxHistory
# Step 1: Construct Subs
for each row Row of Profiles
for m from 1 to maxHistory
for each unique length-m subseq Seq of Row
Subs := Subs unioned with {Seq}
end
end
end

count(s1 ) = 1 P (s1 ) = 0.17
count(s2 ) = 3 P (s2 ) = 0.50
count(s3 ) = 2 P (s3 ) = 0.33
Given that s immediately precedes ei , the conditional
probability of ei is
P (ei |s) =

# Step 2: Construct Distributions
for each row index i of Subs
m := length of Subs(i)
numTotal := number of length-m subseq in Profiles
for each unique element e in Profiles
Seq := row i of Subs concatenated with e
numSeq := number of occurrences of Seq in Profiles
Distributions(e, i) := numSeq / numTotal
end
end

P (s1 , s2 , . . . , sS , ei )
.
ΣE
j=1 P (s1 , s2 , . . . , sS , ej )

Note that P (ei |s) can be thought of as P (ei ) when s has
length 0. This is not the same as P (ei |IN IT ), which is the
probability that event ei is the ﬁrst event in the sequence,
occurring immediately after IN IT . Rather, P (ei |s) is the
probability of ei given no information about the events that
precede it.
A probabilistic EFG (PEFG) is created by annotating each
event (node) in the EFG with a table containing the event’s
prior probability and its probability conditioned on each
subsequence in {r1 , r2 , . . . , rR } up to some maximum subsequence length, or history, H. Each set of entries for all
length-h subsequences, 0 ≤ h ≤ H, succinctly encodes a
probabilistic Markov model whose O(E h ) nodes correspond
to length-h subsequences and whose edges are labeled with
conditional probabilities. Table 1 shows a conditional probability table of event e1 for subsequences of events up to
length 5 for the EFG shown in Figure 2. Zero-probability
entries are omitted. The ﬁrst data row in the table gives the
prior probability of e1 .
h
IN IT
e2
e3
e1 , e3
e2 , e2
IN IT, e1 , e3
e2 , e2 , e2
e1 , e2 , e2 , e2
IN IT, e1 , e2 , e2 , e2

# Step 3: Construct BestPrefixes
for each unique element e in Profiles
i := index such that Subs(i) = e
Prefixes(e) := row indices of Subs for rows
with first element INIT and last sequence element e
BestPrefixes(e) := element j of Prefixes(e) such that
Distributions(j, e) is the
maximum in its column
end
# Step 4: Generate TestSuite
Maxes := index (indices) of row(s) with max value in each
column of Distributions for each element index i of Maxes
KeyEvents := row i of Subs
Prefix := BestPrefixes(first element of KeyEvents)
TestCase := Prefix concatenated with KeyEvents
TestSuite := TestSuite unioned with {TestCase}
end
Output: TestSuite

P (e1 |h)
0.3125
1.0
0.25
1.0
1.0
0.5
1.0
1.0
1.0
1.0

Figure 3: Test case generation algorithm

of usage proﬁles and the output set of test cases, are stored
as matrices in which each row holds an event sequence and
the ith column of a row holds the ith event in the sequence.
The algorithm takes two parameters: Profiles, the set of
usage proﬁles, and maxHistory, the maximum number of
previous events on which the probability calculations are to
be conditioned. The output is TestSuite, a set of test cases.
In Step 1, the Subs matrix is constructed by adding in
each unique event subsequence up to length maxHistory in
Profiles. In Step 2, the probability distribution P (e|i) is
computed for each unique event e in Profiles and each
row i in Subs and is stored in Distributions. For each
unique event e, Step 3 calculates the probability of each path
from INIT to e. Finally, in Step 4, the matrix TestSuite is
constructed by adding a legal test case (i.e. one that begins
with INIT) for each column maximum in Distributions.

Table 1: Probabilities relating to Figure 2

3.3 Generating test cases
In general, there are two ways to use a probabilistic test
case generation model. Test cases can be generated that exercise the most probable sequence of events, given a range
of starting points and test case lengths. Alternatively, test
cases (i.e., event sequences) can be generated based on concatenating pairs of events that have the highest probability
of occurring. For the study presented in this paper, the latter method is used, in order to determine the eﬀectiveness
of highly probable pairs of events. All possible test cases are
generated, based on the events observed during usage proﬁle
collection, up to a speciﬁed history provided by the tester.
The algorithm in Figure 3 generates test cases by constructing and traversing the probabilistic EFG. In the pseudocode shown, sets of event sequences, such as the input set

4. EMPIRICAL STUDY
We conducted an empirical study to evaluate the eﬀectiveness of our model-based test case generation technique
(pefg) in relation to replaying the usage proﬁles “as-is”
(profiles), without using the probabilistic EFG. The study
answered the following questions:
1. Is the pefg test suite more eﬀective at fault detection
than the profiles test suite?
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2. Is the cost of testing using the pefg technique less
than that of the profiles technique?

the JavaGUIRipper creates an XML ﬁle that represents the
windows, menu items, and buttons present in the GUI, including the actions that are executed when those items are
selected.
Another tool in the suite, the JavaGUIReplayer, was used
for test case execution. The JavaGUIReplayer is a framework that opens the application under test and replays test
cases. Each event is executed on the GUI, and the state
of the GUI is recorded after each step. The state is saved
in XML ﬁles that can be examined to determine which test
cases failed and why.
Usage proﬁles can be captured by a tool in GUITAR’s
family of applications called the Proﬁler [16]. (The Proﬁler does not currently belong to GUITAR’s canonical, publicly available set of tools.) Running the subject application
through Java Reﬂection, the Proﬁler attaches its own event
handlers to each JButton, JTextArea, and JMenuItem that
becomes visible. When one of the Proﬁler’s event handlers
is triggered, the Proﬁler records an identiﬁer for the widget
and the type of event.

3. Does reducing the history parameter in the pefg technique (down to some minimum length) decrease the
cost of testing without decreasing the eﬀectiveness of
the test suite?
Under the assumption that the usage proﬁles used to populate the probabilistic EFG are representative of usage in the
ﬁeld, the ﬁrst question implies that the pefg technique is
more eﬀective at ﬁnding faults than replaying the usage proﬁles directly. In order to compare the results of test suites
of diﬀerent sizes, test suite eﬀectiveness was normalized by
computing fault density, that is, the number of faults detected by a test suite, divided by the number of test cases
in that test suite. More formally,
F (pefg, h)
|pefg|

>

F (profiles)
|profiles|

(1)

where F (suite, history) is the number of faults detected by
suite with a history value of history 5 . Test suite eﬀectiveness was determined by running each test case on each subject application. Failed test cases are those that caused the
application to encounter an uncaught exception during test
case execution. After collecting the set of failures, each was
manually linked to the fault that caused it. This approach
has been used before and has been found to be useful [25,26].
The second question relates to the cost of generating and
executing test cases, and proposes that the pefg technique
will be cheaper than executing the proﬁles directly as test
cases, or
c(profiles) > c(pefg, h),

4.2 Subject applications
Four popular open source applications developed in Java
Swing were chosen for this study and downloaded from SourceForge:
1. CrosswordSage 0.3.56 , a popular tool for creating and
solving professional-looking crossword puzzles with builtin word suggestion capabilities, with an all-time activity rate of 76.87%.
2. FreeMind 0.8.07 , a very popular mind-mapping application, with an all-time activity rate of 99.96%.

(2)

where c(suite, history) is the cost of testing that suite with
a history value of history. As a proxy for cost, the size of
the test suite was used. In the context of this study, using
the size of the test suite rather than the length of the test
cases is reasonable since the overhead required to run each
test case, including starting the test case execution framework, starting the application, and ending the application
and framework, consumed more computation time than any
other activity. The goal of developing a cost value for each
test suite is to use it as a comparison measure. Computing
cost based on the size of the test suite allows valid comparison of our method to work performed by others using this
suite of tools, since the cost of executing test cases will be
the same.
The third question asserts that, if the minimum suﬃcient
history length is known or estimated for some application,
the cost of testing the application can be reduced without
loss of fault detection ability, determined by the following:
F (pefg, h) ≈ F (pefg, h − n)∧
c(pefg, h) > c(pefg, h − n)

3. GanttProject 2.0.18 , a project scheduling application
featuring Gantt chart, resource management, calendars, and the option to import/export MS Project,
HTML, PDF, and spreadsheets, with an all-time activity rate of 99.85%.
4. jMSN 0.9.9b29 , a clone of MSN Messenger, including
instant messaging, ﬁle sharing, and additional chat features standard in MSN Messenger, with an all-time
activity rate of 93.81%.
These applications were chosen for several reasons. First,
they all have an active developer community and high alltime-activity scores on SourceForge, with three of the applications above 90%. CrosswordSage was chosen partially
because it is fairly new (ﬁrst released in 2005) and yet has
an activity score of almost 80%. These applications have
also been released in several versions and have undergone
quality assurance prior to each release.
Preparation for testing the applications included setting
up a database for text-ﬁeld values. In order to automate
test case replaying, a database that contains one instance for
each of the text types in the set {negative number, real number, long file name, empty string, special characters, zero,
existing file name, non-existent file name} was used. Note
that if a text ﬁeld is encountered in the GUI (represented as

(3)

where h−n represents the minimum suﬃcient history length.

4.1 Infrastructure
The GUI Testing FrAmewoRk (GUITAR) was used to
perform the study [14]. The JavaGUIRipper, one of the
tools in the GUITAR suite, was used to glean the structure of the subject applications. By using Java Reﬂection,

6

http://sourceforge.net/projects/crosswordsage
http://sourceforge.net/projects/freemind
8
http://sourceforge.net/projects/ganttproject
9
http://sourceforge.net/projects/jmsn
7

5
History only applies to the pefg test suite, given as a parameter to the model
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an event called type-in-text), one instance for each text
type is tried in succession. We also set up the test oracle
to detect crashes for these applications, where a crash is
deﬁned as an uncaught exception thrown during test case
execution.

<Profile>
<Step>
<Window>GanttProject_1</Window>
<Component>New..._R_33</Component>
<Action>doClick</Action>
<WindowFlag>FALSE</WindowFlag>
<Attributes>
<Property>
<Name>IconImage</Name>
<Value>IconImage_24</Value>
</Property>
<Property>
<Name>Type</Name>
<Value>RESTRICTED</Value>
</Property>
<Property>
<Name>ReplayableAction</Name>
<Value>doClick</Value>
</Property>
<Property>
<Name>Visible</Name>
<Value>TRUE</Value>
</Property>
<Property>
<Name>Enabled</Name>
<Value>TRUE</Value>
</Property>
</Attributes>
</Step>
<Step>
<Window>Create new project_2</Window>
<Component>AutoText_R_0</Component>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
</Step>
<Step>
<Window>Create new project_2</Window>
<Component>AutoText_R_2</Component>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
</Step>
<Step>
<Window>Create new project_2</Window>
<Component>AutoText_R_1</Component>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
</Step>
<Step>
<Window>Create new project_2</Window>
<Component>AutoText_R_9</Component>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
</Step>
<Step>
<Window>Create new project_2</Window>
<Component>Cancel_R_23</Component>
<Action>doClick</Action>
<WindowFlag>FALSE</WindowFlag>
</Step>
</Profile>

4.3 File formats and examples
Usage proﬁles and test cases are both stored in an XML
format understood by the JavaGUIReplayer. An example of
one usage proﬁle, the corresponding entries in the map and
matrix ﬁles, and a test case resulting from the model are
shown below. For the sake of space, only a few attributes
are shown, and only on the ﬁrst step. In a full proﬁle or test
case, there are 16 attributes for each step.
Figure 4 shows a partial usage proﬁle for GanttProject.
This proﬁle is composed of six steps, which together make
a new GanttProject, and set some of the project speciﬁcs
in the “Create new project” window. Finally, Cancel is selected, which will cancel all of the user actions for creating
the new project.
The following lines, each representing one usage proﬁle in
the “matrix” ﬁle to be used by the test case generation algorithm, represent a usage proﬁle in an abbreviated format;
each number represents one event in the proﬁle.
1 2 3 4 7 9
1 2 10 3 12 7
1 2 3 12 5 7
The “map” ﬁle is the translator between the proﬁle and
the matrix. The portion of the map ﬁle shown here describes
the events in the sample usage proﬁle and one line of the
matrix.
1 <Window>GanttProject_1</Window><Component>New..._R_33
</Component><Action>doClick</Action>
2 <Window>Create new project_2</Window><Component>AutoText_R_0
</Component><Action>setText_String_5</Action>
3 <Window>Create new project_2</Window><Component>AutoText_R_1
</Component><Action>setText_String_5</Action>
4 <Window>Create new project_2</Window><Component>AutoText_R_9
</Component><Action>setText_String_5</Action>
7 <Window>Create new project_2</Window><Component>Cancel_R_23
</Component><Action>doClick</Action>
9 <Window>Create new project_2</Window><Component>AutoText_R_2
</Component><Action>setText_String_5</Action>

After running the test case generation algorithm (Section 3), a map and matrix were produced for the generated
test suite. The resulting matrix ﬁle was expanded into test
case events, based on the numbers assigned in the mapping,
and test cases were generated. The following line is an example of a test case generated by the algorithm; this exact
sequence of events did not occur in the set of proﬁles.

Figure 4: Partial usage profile for GanttProject

1 2 10 3 12 7 1

event sequences of length 1 or 2, maxLength was set to 5
for this study [14]. Fault detection eﬀectiveness for each sequence length up to 5 is examined, to determine the optimal
level. In some applications, a sequence length of 5 required
roughly twice as much time for test case generation and processing.
The original matrix, such as that shown above, encoded
the test suite for the profiles technique, and the matrix
output by Matlab (TestSuite in Figure 3) encoded the test
suite for pefg. Finally, using the mapping from integers
to event identiﬁers, both matrices were expanded into XML
test cases for JavaGUIReplayer.
Each test case was run using the JavaGUIReplayer, us-

An example of a generated test case is shown in Figure 5.

4.4 Generation and execution of test suites
The usage proﬁles were processed in several stages to create replayable test cases. First, the usage proﬁles were distilled into a matrix of integers (Profiles in Figure 3) and
a mapping from each integer in the matrix to the textual
event identiﬁer it represents. From this matrix, test cases
were generated by a Matlab implementation of our test case
generation algorithm.
Based on previous research which showed that event sequences of length 3 reveal substantially more faults than
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4.5 Threats to Validity

<Testcase>
<Step>

The results of this study should be interpreted with some
deference to threats to validity. First, due to our desire to
use the existing GUITAR infrastructure, and to compare
our results to those posted by previous graduate student researchers, we used subject applications developed in Java.
Therefore, we have no information on how the results would
translate to other development languages. Also, although
the GUI for each application is diﬀerent, they do not reﬂect
all possible classes of GUIs. Furthermore, the majority of
the application code is written for the GUI, meaning the
results may not be consistent for applications with a simple GUI and complex underlying business logic. Second,
although the applications chosen for this study have undergone quality assurance, they are open-source and developed
by volunteers, leading to the possibility that they are more
prone to bugs than professionally developed software.

<Action>doClick</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>GanttProject_1</Window>
<Component>New..._R_33</Component>
<Attributes>
<Property>
<Name>Title</Name>
<Value>New..._R_33</Value>
</Property>
<Property>
<Name>Class</Name>
<Value>javax.swing.JMenu$1</Value>
</Property>
<Property>
<Name>Enabled</Name>
<Value>TRUE</Value>
</Property>
<Property>
<Name>Visible</Name>
<Value>TRUE</Value>
</Property>
<Property>
<Name>Type</Name>
<Value>RESTRICTED</Value>
</Property>
</Attributes>
</Step>
<Step>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>Create new project_2</Window>
<Component>AutoText_R_0</Component>
</Step>
<Step>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>Create new project_2</Window>
<Component>AutoText_R_2</Component>
</Step>
<Step>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>Create new project_2</Window>
<Component>AutoText_R_9</Component>
</Step>
<Step>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>Create new project_2</Window>
<Component>AutoText_R_4</Component>
</Step>
<Step>
<Action>setText_String_5</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>Create new project_2</Window>
<Component>AutoText_R_1</Component>
</Step>
<Step>
<Action>doClick</Action>
<WindowFlag>FALSE</WindowFlag>
<Window>GanttProject_1</Window>
<Component>New..._R_33</Component>
</Step>
</Testcase>

5. RESULTS
The fault density of the pefg test suite was better than
the profiles test suite on all four applications. The test
suites produced by the model, referred to as the pefg test
suites, were consistently smaller than the original profiles
test suites, reducing the time and computation resources
required for producing and executing the test suites. Table 2
shows the diﬀerence in the test suite sizes. Finally, for the
set of usage proﬁles used as input, the most eﬀective history
length was 5.

5.1 Fault Detection

Figure 6: Fault density
In order to determine if the pefg test suite detects more
faults per test case than the profiles test suite, Equation 1
was computed, shown in Figure 6. The pefg test suite for
CrosswordSage produced 123 faults, compared to 111 faults
detected by the profiles test suite. In all four applications,
the fault density of the pefg test suite was better than that
of the profiles test suite. FreeMind’s pefg test suite detected 111 faults, while the profiles test suite detected 200.
jMSN’s pefg and profiles test suites detected 1135 and 76
faults, respectively. There was a rather large diﬀerence in
test suite size for GanttProject (Table 2), which greatly impacted the fault density for the test suites (Figure 6). The
pefg test suite found 308 faults, while the profiles test
suite found 258.

Figure 5: Partial generated test case

ing one machine per application in a cluster of PCs running Linux. The overall process executed in approximately
4 hours per application. Pre-processing the usage proﬁles
for the model took approximately 5 minutes, model creation took approximately one hour, and test case generation
took about 30 minutes. Finally, test case execution took 2-3
hours. There is no interaction between the test cases, meaning the results of one do not inﬂuence the results of another.
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Additionally, the pefg test suite found faults not found
in the profiles test suite in two applications. The pefg
test suite found 5 faults in CrosswordSage and 2 faults in
jMSN that were not detected by the profiles suite. The
faults are uncaught exceptions related to incorrect state of
the application, resulting in an error of ”Wrong index for
this event.”

other approaches, which has been shown to some degree in
this work.
By generating the pefg test suite and drastically decreasing the size of the test suite – roughly 0.2%-22% of the size
of the profiles test suites – the cost of testing has been
reduced. This can be partially explained by the fact that
many users will execute not only the same events, but also
very similar event sequences. The pefg test suite would
then be much smaller because the use of probabilities eﬀectively collapses the sequences and gives more weight to the
common sequences.
The best results are obtained by using a history value of
5, yielding 100% fault detection. We initially hypothesized
that a history value of 3 would provide suﬃcient fault detection, but this is not the case in these test suites, which
may be due to the length of the usage proﬁles. In general, longer usage proﬁles, much like longer test cases, will
train the model more eﬀectively and thus generate better
test cases. The usage proﬁles in this study contain, on average, 9 events, which is relatively short. Ideally, proﬁles of
20 events or more are desirable to provide a more accurate
insight into actual usage of the application.

5.2 Cost
Application
CrosswordSage
FreeMind
GanttProject
jMSN

profiles
1903
58301
199139
6852

pefg
248
171
762
1484

Table 2: profiles and pefg test suite sizes for each
application
The cost of executing each test suite, i.e., the size, was
computed using Equation 2. Comparing these costs, as
shown in Table 2, it can be seen that the pefg test suites are
consistently smaller than those of the profiles test suites.
Therefore, less resources are required to generate and execute the test suites.

6. CONCLUSIONS AND FUTURE WORK
The model presented in this paper was demonstrated in
the context of automated regression testing of GUI applications. The foundation of the model is collecting usage
information from real users of the application, and applying
that information to test case generation. Well-known probabilistic methods were used to develop a model, which was
in turn used to generate test cases. Processing the collected
proﬁles through the model produced smaller test suites with
better fault detection per test case than the profiles test
suites.
User-proﬁle based testing naturally lends itself to applications in regression testing. In order to avoid the complexity
of unexecutable test cases, regression testing of multiple versions of the open source applications was not demonstrated
in this study. Collecting usage proﬁles on one version and
using them to populate a model of a subsequent version will
require some extensions to the model in order to map from
one EFG to the other, and is a planned extension of this
research. Based on work by Weyuker [20], we will also deﬁne coverage criteria for this technique, which will help to
identify new parts of the application that are not covered
by any of the existing usage proﬁles.
In the future, the test case generation algorithm can be
improved. Currently, the algorithm selects event sequences
that contain at least one highly probable n-tuple of events,
but the probability of the whole event sequence, and therefore the test case, may be very low. For example, if P (e2 |e1 ) =
0.999, the algorithm will construct a test case that contains
the sequence e1 , e2 , even if e1 is only exercised in 0.001% of
the usage proﬁles collected. We will modify our algorithm
to use techniques which consider the probability of a whole
sequence of events in generating a test case. Another variation of the algorithm is to traverse the least likely paths
in the PEFG to reveal rarely-encountered faults that may
otherwise be diﬃcult to detect.
Many of the generated test cases for CrosswordSage did
not complete because of one event they had in common: the
Save event. The test cases failed when the Save event was
replayed, due to the event not being enabled at that point

5.3 History
Using Equation 3, the fault detection and cost of each
history level can be compared, as shown in Figure 7. It is
important to note that for any history, h, all prior histories
are alsoP
used, so the faults detected using a history of n
include n
h=1 F (suite, n). Using a history of 5 in preparing
the pefg test cases produced test cases that detect 100% of
faults.

Figure 7: Faults for varying levels of history

5.4 Discussion
The fault detection eﬀectiveness of the pefg test suite
shows the validity of the model-based test case generation
technique presented here. Although the model can be improved to detect more faults, the test cases do detect faults
not detected by using the original proﬁles as test cases. One
of the motivating factors of this research is to detect faults
that will be discovered by users and are not detected by
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in the test case execution, because the test cases did not
ﬁrst execute Open or New. The current test case generation
algorithm does not have any notion of dependency, and does
not enforce business logic such as “Execute an Open or New
before a Save.” This will be addressed in future versions of
the algorithm.
Finally, training the model to detect diﬀerent classes of
users, and generating test cases based on these classes, will
provide another level of insight into the usage of the application. Because the process is automated, developing test
suites based on the user class will not be more diﬃcult, and
could uncover faults that would not be detected in the single
user class model presented here.
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